Cortex Query Language (XQL) queries usually begin by defining a data source, be it a dataset, preset, or Cortex Data Model (XDM). You must specify the dataset mapped to the XDM that you want to run your query against. In a dataset query, unless otherwise specified, the query runs against the `xdr_data` dataset, which contains all log information that Cortex AgentiX collects from all Cortex product agents, including EDR data, and PAN NGFW data. It's possible to change the default dataset in the **Dataset Management** page of Cortex XSIAM. For more information, see [What are datasets?](../../../configure-cortex-xsiam/data-management/dataset-management/what-are-datasets).
After specifying a data source, you use zero or more stages to form the XQL query. Each stage is delimited using a pipe character (`|`). The function performed by each stage is identified by the stage keyword that you provide. XQL queries can contain different components depending on the type of query you want to build.
### **Adding comments in queries**
You can add comments in any section when building a query in Cortex Query Language (XQL).
* Comments are added on a single line using the following syntax.
```programlisting
//<comments>
```
For example,
```programlisting
dataset = xdr_data
| filter event_type=1
//ENUM.process
and event_sub_type = 1
//ENUM.execution
```
* To write a comment that extends over multiple lines use the following syntax.
```programlisting
/*multi-line <comments> */
```
For example,
```programlisting
dataset = xdr_data
| filter
/*multi-line Adding comments is a great thing.
Here is an example */
event_type=1
```